Connecting a PeaceFair Pzem-004T to an Espressif ESP8266


#102

Used Pc yes because couldn’t fiind it in the Play Store on the first Android device. See other message where I say I did find another Android tablet in my “stock” :slight_smile:


#103

As said below, couldn’t find it with one device but ok with other Android device … Must be Android version probably


#104

Actually after 6 hours of being connected to my router the hostname has just changed from ESPproMonTony to ESP_5A03E0. Edit: this was because I had cleared the EEPROM from the app.
There is a bug in the ESP8266 Arduino firmware relating to hostnames and a fix has been produced but it’s not in the official ESP8266 Arduino release yet. We rolled back to a supposedly pre bug version for the bin file we sent to you.


#105

Costas, I am carefully optimistic now ! I think that what I suspected for a while is correct. There’s something wrong with the provisioning process when using the IOS App. I think the settings of the WIFI network it needs to connect to are not “written” correctly to the EEPROM or something alike … It has been running for 20 minutes now using the Android App for provisioning … Fingers crossed ! :slight_smile:


#106

I will run some tests with our iPhone and the ESPproMonTony running here. For the last 6 hours it’s been running with Android.

OK initial test for the iPhone is OK. It’s not a full test but you will glad to know that once an ESP8266 is provisioned via Android it is automatically provisioned and ready to run on iPhone. All you have to do is login with the same username and password.

I will do a full test now of provisioning on iPhone for a new user. Results to follow.


#107

Okay … I will let it run until it has done 1 hour. Then I will power off, power on and see if it has retained it’s Wifi data, OK ?


#108

Yes check after 1 hour.


#109

I’m not an iPhone user and we only bought an old iPhone purely for testing with ESPproMon.
Been a long time since I provisioned this one but I will try to make a note of the differences between this and Android.


#110

Done a full provisioning with iPhone and it worked first time without any problems.
It is slightly different to Android but the phone clearly prompts you for the steps to take.
The fact that it doesn’t give a drop down list of SSID’s to select from shouldn’t really be an issue as it uses the last one you were connected to, which is correct. Failing that just switch to the correct SSID before starting the provisioning.

This ESP8266 has now only been provisioned by iPhone without the need for an Android phone.
Been running for 10 minutes in demo mode so far.


#111

@Tony think you have now been running for 1 hour and from our side it shows you are still connected to the cloud server, correct?

Just check the hostname in the router and it should be ESPproMonTony.

You can then try the WeMos in the PCB, but without the Pzem.


#112

Ok … Mine has been running for an hour now … Never broke that record before ! :slight_smile:

Power Off and On again : Android App reports lost connection. ESPProMon shows up again as SSID ! No way to reconnect the App so same result as with IOS App … Damn !!!


#113

Strange,I can think of 2 possibilities:

  1. Your account has somehow corrupted on our server.

  2. You have faulty RAM.

To test 1.
Using iPhone, as that’s your main phone, logout of our server by pressing the icon at the top right hand corner in the app.
Sign in with a new account (use your Gmail account), scan the QR code at https://peacefairapp.com/ and provision the ESP8266 again. You can keep the ESP in the PCB but without the Pzem. After a few minutes reboot the ESP.

Edit: I have disabled your original login credentials.


#114

Costas, faulty RAM is not possible as I tested it with 2 different Wemos boards.

OK signed out, then clicked on create new account. Entered my gmail address and a password, got this :slight_smile: (really no luck for me)


#115

I have changed the password on your old account and logged into the server via the app with the new password.
Provisioned our WeMos here with your account and rebooted the WeMos 3 times and the EEPROM is not being cleared. This suggests your old account on our server is fine.

I will send you the password via PM so you can connect to our WeMos but first we need to find out why the app / QR code is not available to you.

I assume your internet is running? Have you tried clicking the refresh at the top right of the screen?

Try closing the app and logging in again. If this fails try removing the app and re-installing.


#116

Internet is fine. Refresh button gives same result. Killed the App and restarted it. All referring to the IOS App.

To what email address did you send the Pwd ? Gmail or Live ?


#117

I haven’t sent the pwd yet but it will be for your old live account and I will send it via this forum and post here when I send it.

Are you able to log in with your gmail account?


#118

I’m going to need your flashing procedure to see if somehow you are allocating the wrong RAM size etc.


#119

Yes no problem


#120

Here are the settings for flashing the Wemos :


#121

WeMos is not a 4Mbit device it’s a 32Mbit.