Provisioning your ESP8266 with our server


#11

@karthi

Have you worked through the guides that tell you which pins to connect from the Pzem to the ESP8266?

You can’t use an Uno or Mega with our app but the ESP8266 12E should be fine.

Do you know how to wire up the Pzem and where are you picking up the 5V input for it?


#12

yes i used uno for testing pzem. for powering 5v taken from NODE MCU’s Vin

pin which is 5V coming from from USB.


#13

@karthi please upload a photo showing your Pzem and ESP all wired up.


#14

ok. Now i’m in workplace, after 2hours i’ll reach my house will work on that.

thank you for your fastest response.


#15

here is the pic of NODE MCU to PZEM

PZEM 5V–> Node mcu Vin
RX --> TX
TX–> RX
GND—> GND


#16

@karthi thanks for the photo. The TX and RX on the Pzem don’t go to the RX and TX pins on the ESP8266.

We have allocated specific GPIO pins for the RX and TX connections on the ESP8266.

Please look through this thread Connecting a PeaceFair Pzem-004T to an Espressif ESP8266


#17

I made the changes accordingly. i Flashed Node MCU with the firmware. now i want to register my device right?


#18

You should be able to use the firmware without registering it. Once you know it all works then you can register it.


#19

ok, for flashing firmware i used nodemcu-flasher

this Settings ok or i need to use esp8266 download tool?


#20

That flasher should be fine but we have found some users don’t know what size their flash chip is and have wrongly used 1M when it’s a 4M.

Our firmware will run with an incorrect flash size but it will not store the required access credentials to interface with our server.


#21

hi successfully my device came online, but during provisioning timed out error

arise however device came into online.

now in DEMO mode it shows values. if i turn down the demo not receiving any data in app.

Also After Resetting esp again it entered in to access point mode.


#22

Hard reset with the button on the ESP8266 or the reset in the app.

If it continues to return to AP mode it probably means you flashed it incorrectly.


#23

Hardware reset on ESP, where can i find latest firmware?


#24

You have the latest firmware as shown in the flashing tool.

Paste a copy of your settings from the Advanced page of the tool.


#25

Settings


#26

I just tried flashing my NodeMCU with that 2015 tool and it didn’t bring up an AP at all.

Espressif tool is better as it’s updated regularly.

Will just do a few more checks with the tools you are using and report back to you.


#27

Second flash with that old tool didn’t work.

Use the tool and settings from Connecting a PeaceFair Pzem-004T to an Espressif ESP8266


#28

i tried with esptool. now its working. its not going back to access point…:grinning:


#29

Think you should have flashed it as DIO not QIO.


#30

Hai sorry for delay as a new user i can’t post more than 17 messages.

With demo mode it Shows random data on all the super charts.

Demo mode in Off State i am not getting any data from PZEM.