Provisioning your ESP8266 with our server




I just tried flashing my NodeMCU with that 2015 tool and it didn’t bring up an AP at all.

Espressif tool is better as it’s updated regularly.

Will just do a few more checks with the tools you are using and report back to you.


Second flash with that old tool didn’t work.

Use the tool and settings from Connecting a PeaceFair Pzem-004T to an Espressif ESP8266


i tried with esptool. now its working. its not going back to access point…:grinning:


Think you should have flashed it as DIO not QIO.


Hai sorry for delay as a new user i can’t post more than 17 messages.

With demo mode it Shows random data on all the super charts.

Demo mode in Off State i am not getting any data from PZEM.


That suggests the Pzem might still not be wired up correctly.
Is the current transformer connected around a live power feed?

Did you change the rx and tx connections on the ESP as they are wrong in your photo as per our ealrier post?


@karthi also on the TARIFF page if you scroll down does the STATUS show in yellow as Registered?

If it doesn’t select parameter 28 Validate Firmware from the drop down parameter menu and check the STATUS again.


now firmware Registered.

still not getting Data.

and ESP8266 continuously restarts for every seconds. is there something went wrong?


This is normally because the Pzem and ESP are wired up incorrectly and sometimes due to a bad flash.

I would flash the ESP again as DIO unless you specifically know that you should be using QIO.

Post some photos clearly showing how you have wired up your system.


I used separate 5v supply from regulator and once again I flashed firmware now resetting issue cleared.


Are you saying everything is ok now?


No, I am not getting data from pzem otherwise everything is good.


@karthi for development boards like the NodeMCU and WeMos you shouldn’t need to use a separate 5V supply. Us the 5V on the board. Below is a photo from a user we helped out yesterday. It’s probably best to play safe and use the voltage divider as shown in the photo and advised in item 4 of Having Problems with Your Peacefair Pzem-004T

Check the wiring against yours and let us know how it goes.


Yes, Actually i am powering Node mcu with USB power and PZEM powered separately

and i used voltage dividers also for PZEM TX pin which is connected in D6 pin of Node MCU…

no LUCK…

In APP side any specific setting is there?

do i need to set Any API KEY?


No that is for integration with 3rd party IOT networks and can’t be set until the Pzem is providing the data.


am I receiving. -1 datas from Pzem??


-1 is the default from the Pzem when there is a problem.


The ESPproMon app keeps returning to “Please configure the device” after I went through the steps to connect to my Wifi network, connect to the device (SSID ESPPro) and passing through connecting to cloud. The Wemos D1 mini was flashed to the latest software. I tried provisioning using another new account and the error repeated (so far on 3 Wemos devices). I checked my router and the Wemos is connected to my home network after provisioning.

What should I do next ? The Wemos is not connected to the PZEM 004 yet.


I would like to know how you did to load the firmware in the esp. I have problems with that